// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?six)\b(?:[a-z](?:[a-z\n\r.:;,?!-]*[a-z])?)\b").unwrap();
let string = "How do I match text with a regular expres
sion ignoring punctuation and line breaks?
How do I do \"find these words pos-
sibly separated but some non-alphanumeric characters\"?";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}