$re = '/\b(?:[a-z](?:[a-z\n\r.:;,?!-]*[a-z])?)\b/six';
$str = 'How do I match text with a regular expres
sion ignoring punctuation and line breaks?
How do I do "find these words pos-
sibly separated but some non-alphanumeric characters"?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);