using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:[a-z](?:[a-z\n\r.:;,?!-]*[a-z])?)\b";
string input = @"How do I match text with a regular expres
sion ignoring punctuation and line breaks?
How do I do ""find these words pos-
sibly separated but some non-alphanumeric characters""?";
RegexOptions options = RegexOptions.Singleline | RegexOptions.IgnoreCase | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}