re = /\b(?:[a-z](?:[a-z\n\r.:;,?!-]*[a-z])?)\b/ix
str = 'How do I match text with a regular expres
sion ignoring punctuation and line breaks?
How do I do "find these words pos-
sibly separated but some non-alphanumeric characters"?'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end