import re
regex = re.compile(r"""
\b(?:[a-z](?:[a-z\n\r.:;,?!-]*[a-z])?)\b
""", flags=re.DOTALL | re.IGNORECASE | re.VERBOSE)
test_str = ("How do I match text with a regular expres\n"
"sion ignoring punctuation and line breaks?\n"
"How do I do \"find these words pos-\n"
"sibly separated but some non-alphanumeric characters\"?")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")