using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^\P{P}-]+";
string input = @"Hello, I am Ed. I am amazing!!! Look!? What do you mean?????
If anything, I think that it's high time to test sentences like this; dont you?!";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}