// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[^\P{P}-]+").unwrap();
let string = "Hello, I am Ed. I am amazing!!! Look!? What do you mean?????
If anything, I think that it's high time to test sentences like this; dont you?!";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}