const regex = new RegExp('[^\\P{P}-]+', 'g')
const str = `Hello, I am Ed. I am amazing!!! Look!? What do you mean?????
If anything, I think that it's high time to test sentences like this; dont you?!`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}