$re = '/[^\P{P}-]+/';
$str = 'Hello, I am Ed. I am amazing!!! Look!? What do you mean?????
If anything, I think that it\'s high time to test sentences like this; dont you?!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);