import Foundation
let pattern = #"[^\P{P}-]+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Hello, I am Ed. I am amazing!!! Look!? What do you mean?????
If anything, I think that it's high time to test sentences like this; dont you?!
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)