package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^\P{P}-]+`)
var str = `Hello, I am Ed. I am amazing!!! Look!? What do you mean?????
If anything, I think that it's high time to test sentences like this; dont you?!`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}