re = /[^\P{P}-]+/
str = 'Hello, I am Ed. I am amazing!!! Look!? What do you mean?????
If anything, I think that it\'s high time to test sentences like this; dont you?!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end