#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([0-9]{4}(?: +| *- *)[0-9]{4}(?: +| *- *)[0-9]{4})"
Local $sString = "0000 0000 0000" & @CRLF & _
"0000-0000-0000" & @CRLF & _
"" & @CRLF & _
"123412341234" & @CRLF & _
"1234-12341234" & @CRLF & _
"12341234-1234"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")