package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([0-9]{4}(?: +| *- *)[0-9]{4}(?: +| *- *)[0-9]{4})`)
var str = `0000 0000 0000
0000-0000-0000
123412341234
1234-12341234
12341234-1234`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}