using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([0-9]{4}(?: +| *- *)[0-9]{4}(?: +| *- *)[0-9]{4})";
string input = @"0000 0000 0000
0000-0000-0000
123412341234
1234-12341234
12341234-1234";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}