// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([0-9]{4}(?: +| *- *)[0-9]{4}(?: +| *- *)[0-9]{4})").unwrap();
let string = "0000 0000 0000
0000-0000-0000
123412341234
1234-12341234
12341234-1234";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}