import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([0-9]{4}(?: +| *- *)[0-9]{4}(?: +| *- *)[0-9]{4})";
final String string = "0000 0000 0000\n"
+ "0000-0000-0000\n\n"
+ "123412341234\n"
+ "1234-12341234\n"
+ "12341234-1234";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}