re = /([0-9]{4}(?: +| *- *)[0-9]{4}(?: +| *- *)[0-9]{4})/m
str = '0000 0000 0000
0000-0000-0000
123412341234
1234-12341234
12341234-1234'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end