$re = '/([0-9]{4}(?: +| *- *)[0-9]{4}(?: +| *- *)[0-9]{4})/m';
$str = '0000 0000 0000
0000-0000-0000
123412341234
1234-12341234
12341234-1234';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);