# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^scaloppine di (pollo|maiale) a(lla senape|l vino bianco|l limone|l marsala|lla birra|lla pizzaiola|i funghi)$//gm;t' <<< "scaloppine di maiale alla pizzaiola"