$re = '/^scaloppine di (pollo|maiale) a(lla senape|l vino bianco|l limone|l marsala|lla birra|lla pizzaiola|i funghi)$/m';
$str = 'scaloppine di maiale alla pizzaiola';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;