re = /^scaloppine di (pollo|maiale) a(lla senape|l vino bianco|l limone|l marsala|lla birra|lla pizzaiola|i funghi)$/m
str = 'scaloppine di maiale alla pizzaiola'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result