using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^scaloppine di (pollo|maiale) a(lla senape|l vino bianco|l limone|l marsala|lla birra|lla pizzaiola|i funghi)$";
string substitution = @"";
string input = @"scaloppine di maiale alla pizzaiola";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}