use strict;
my $str = 'scaloppine di maiale alla pizzaiola';
my $regex = qr/^scaloppine di (pollo|maiale) a(lla senape|l vino bianco|l limone|l marsala|lla birra|lla pizzaiola|i funghi)$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";