#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(NOT-AGK-XL\.(?!\w))|AGK-XL\.(?!\w)"
Local $sString = "AGK-XL. and NOT-AGK-XL."
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)