using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(NOT-AGK-XL\.(?!\w))|AGK-XL\.(?!\w)";
string substitution = @"$1";
string input = @"AGK-XL. and NOT-AGK-XL.";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}