re = /(NOT-AGK-XL\.(?!\w))|AGK-XL\.(?!\w)/
str = 'AGK-XL. and NOT-AGK-XL.'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result