import Foundation
let pattern = #"(NOT-AGK-XL\.(?!\w))|AGK-XL\.(?!\w)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"AGK-XL. and NOT-AGK-XL."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)