use strict;
my $str = 'AGK-XL. and NOT-AGK-XL.';
my $regex = qr/(NOT-AGK-XL\.(?!\w))|AGK-XL\.(?!\w)/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";