const regex = /(NOT-AGK-XL\.(?!\w))|AGK-XL\.(?!\w)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(NOT-AGK-XL\\.(?!\\w))|AGK-XL\\.(?!\\w)', 'g')
const str = `AGK-XL. and NOT-AGK-XL.`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);