$re = '/(NOT-AGK-XL\.(?!\w))|AGK-XL\.(?!\w)/';
$str = 'AGK-XL. and NOT-AGK-XL.';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;