#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(>[^<]*)\n([^<]*<)"
Local $sString = "<table>" & @CRLF & _
"<tr><th>HEader 1</th><th> header " & @CRLF & _
"2</th>" & @CRLF & _
"</tr>" & @CRLF & _
"<tr><td>cell " & @CRLF & _
"content</td><td>cell 2</td></tr>" & @CRLF & _
"</table>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")