import re
regex = re.compile(r"(>[^<]*)\n([^<]*<)")
test_str = ("<table>\n"
"<tr><th>HEader 1</th><th> header \n"
"2</th>\n"
"</tr>\n"
"<tr><td>cell \n"
"content</td><td>cell 2</td></tr>\n"
"</table>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")