// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(>[^<]*)\n([^<]*<)").unwrap();
let string = "<table>
<tr><th>HEader 1</th><th> header
2</th>
</tr>
<tr><td>cell
content</td><td>cell 2</td></tr>
</table>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}