import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(>[^<]*)\\n([^<]*<)";
final String string = "<table>\n"
+ "<tr><th>HEader 1</th><th> header \n"
+ "2</th>\n"
+ "</tr>\n"
+ "<tr><td>cell \n"
+ "content</td><td>cell 2</td></tr>\n"
+ "</table>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}