re = /(>[^<]*)\n([^<]*<)/
str = '<table>
<tr><th>HEader 1</th><th> header
2</th>
</tr>
<tr><td>cell
content</td><td>cell 2</td></tr>
</table>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end