using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(>[^<]*)\n([^<]*<)";
string input = @"<table>
<tr><th>HEader 1</th><th> header
2</th>
</tr>
<tr><td>cell
content</td><td>cell 2</td></tr>
</table>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}