package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(>[^<]*)\n([^<]*<)`)
var str = `<table>
<tr><th>HEader 1</th><th> header
2</th>
</tr>
<tr><td>cell
content</td><td>cell 2</td></tr>
</table>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}