using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".* \( ((.+),_(.+)) \)";
string substitution = @"";
string input = @"24_Horn_Trios,_Op.82_(Reicha,_Anton)";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}