use strict;
my $str = '24_Horn_Trios,_Op.82_(Reicha,_Anton)';
my $regex = qr/.* \( ((.+),_(.+)) \)/xp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";