// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?x).* \( ((.+),_(.+)) \)").unwrap();
let string = "24_Horn_Trios,_Op.82_(Reicha,_Anton)";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}