import re
regex = re.compile(r"""
.* \( ((.+),_(.+)) \)
""", flags=re.VERBOSE)
test_str = "24_Horn_Trios,_Op.82_(Reicha,_Anton)"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)