#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "Dossier[^0-9]*\K([0-9]*)(?=-)"
Local $sString = "===========================" & @CRLF & _
" Sousse le 27/09/2012" & @CRLF & _
" Dossier N° 12090343-034 Pvt du : 24/09/2012 à 17:53"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")