$re = '/Dossier[^0-9]*\K([0-9]*)(?=-)/';
$str = '===========================
Sousse le 27/09/2012
Dossier N° 12090343-034 Pvt du : 24/09/2012 à 17:53';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);