use strict;
my $str = '===========================
Sousse le 27/09/2012
Dossier N° 12090343-034 Pvt du : 24/09/2012 à 17:53';
my $regex = qr/Dossier[^0-9]*\K([0-9]*)(?=-)/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}