using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Dossier[^0-9]*\K([0-9]*)(?=-)";
string input = @"===========================
Sousse le 27/09/2012
Dossier N° 12090343-034 Pvt du : 24/09/2012 à 17:53";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}