re = /Dossier[^0-9]*\K([0-9]*)(?=-)/
str = '===========================
Sousse le 27/09/2012
Dossier N° 12090343-034 Pvt du : 24/09/2012 à 17:53'
# Print the match result
str.match(re) do |match|
puts match.to_s
end