import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Dossier[^0-9]*\\K([0-9]*)(?=-)";
final String string = "===========================\n"
+ " Sousse le 27/09/2012\n"
+ " Dossier N° 12090343-034 Pvt du : 24/09/2012 à 17:53";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}