import Foundation
let pattern = #"Dossier[^0-9]*\K([0-9]*)(?=-)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
===========================
Sousse le 27/09/2012
Dossier N° 12090343-034 Pvt du : 24/09/2012 à 17:53
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}