# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([0-9]+)([\s]*)=>([\s]*)([1-9]+)/\1\2=>\3'\4'/;t' <<< "1 => 1"